]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Run offline tests.
[youtubedl] / debian / rules
index 9c645f1c863c90c91a71d29ad84cb96a3d6d86dd..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755 (executable)
@@ -1,17 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --with python2 --buildsystem=python_distutils \
-               --with bash-completion
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
        PREFIX=/usr SYSCONFDIR=/etc make
-       mv Makefile Makefile.inactive
        rm youtube-dl
 
 override_dh_clean:
-       -mv Makefile.inactive Makefile
-       -make clean
+       make clean
        dh_clean
-       rm -rf youtube_dl.egg-info
 
 override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       make offlinetest PYTHON=python3
+endif