Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
d/p/skip-style-checks-for-flake8: Add metadata to please lintian.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 9c645f1c863c90c91a71d29ad84cb96a3d6d86dd..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,17
+1,21
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@ --with python2 --buildsystem=python_distutils \
- --with bash-completion
+ dh $@ --with python3 --buildsystem=pybuild --with bash-completion
override_dh_auto_configure:
PREFIX=/usr SYSCONFDIR=/etc make
override_dh_auto_configure:
PREFIX=/usr SYSCONFDIR=/etc make
- mv Makefile Makefile.inactive
rm youtube-dl
override_dh_clean:
rm youtube-dl
override_dh_clean:
- -mv Makefile.inactive Makefile
- -make clean
+ make clean
dh_clean
dh_clean
- rm -rf youtube_dl.egg-info
override_dh_auto_test:
override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ make offlinetest PYTHON=python3
+endif