]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
debian/{control,manpages,rules,youtube-dl.pod}: Use manpage from upstream.
[youtubedl] / debian / rules
index 504e3570fc9b5df3cb3a4e906663cb3df6e6ecca..4bf82f553e397edddf11732fc317e347b8e9cc16 100755 (executable)
@@ -2,31 +2,8 @@
 %:
        dh $@
 
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
-
 override_dh_python2:
 
 override_dh_pysupport:
 
-
-FULL_VERSION   := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
-TAR_VERSION    := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
-SOURCE         := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
-
-ORIGDIR        = $(SOURCE)-$(TAR_VERSION)
-TARNAME        = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
-
-get-orig-source:
-       rm -rf repack
-       mkdir -p repack/$(ORIGDIR)
-
-       uscan --noconf --force-download --rename --download-current-version --destdir=repack/
-       cd repack; tar zxf $(TARNAME)
-
-       # Remove problematic files
-       rm -f repack/$(ORIGDIR)/youtube-dl.exe
-
-       tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
-       rm -rf repack
+override_dh_auto_test: