]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Drop makefile mangling
[youtubedl] / debian / rules
index 3efd20e1e7d5d89ef75911917e4bf66a5cf3fad7..541ff15d881fd7e8b70fef3a40fba5e0d18fec84 100755 (executable)
@@ -1,15 +1,17 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --with python2 --buildsystem=python_distutils \
-               --with bash-completion
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
        PREFIX=/usr SYSCONFDIR=/etc make
-       mv Makefile Makefile.inactive
        rm youtube-dl
 
 override_dh_clean:
-       test -f Makefile || mv Makefile.inactive Makefile
        make clean
        dh_clean