]> Raphaël G. Git Repositories - youtubedl/blobdiff - debian/patches/01-add-support-to-webm.patch
Imported Debian patch 2010.07.24-1
[youtubedl] / debian / patches / 01-add-support-to-webm.patch
index e1e9a394a460f93fb963bb87fac7f873f2485272..6ff4ac75d0133823f5fa1ee2b66a474175887940 100644 (file)
@@ -1,24 +1,16 @@
-Description: Add support for webm (VP8 video + Vorbis audio)
+Description: Give preference to open video formats
 Author: Rogério Brito <rbrito@ime.usp.br>
 Forwarded: no
-Last-Update: 2010-05-29
+Last-Update: 2010-07-14
 
 --- a/youtube-dl
 +++ b/youtube-dl
-@@ -649,13 +649,15 @@
-       _LOGIN_URL = 'http://www.youtube.com/signup?next=/&gl=US&hl=en'
+@@ -689,7 +689,7 @@
        _AGE_URL = 'http://www.youtube.com/verify_age?next_url=/&gl=US&hl=en'
        _NETRC_MACHINE = 'youtube'
--      _available_formats = ['37', '22', '35', '18', '34', '5', '17', '13', None] # listed in order of priority for -b flag
-+      _available_formats = ['45', '43', '37', '22', '35', '18', '34', '5', '17', '13', None] # listed in order of priority for -b flag
+       # Listed in order of priority for the -b option
+-      _available_formats = ['38', '37', '22', '45', '35', '34', '43', '18', '6', '5', '17', '13', None]
++      _available_formats = ['38', '37', '45', '22', '43', '35', '34', '18', '6', '5', '17', '13', None]
        _video_extensions = {
                '13': '3gp',
                '17': 'mp4',
-               '18': 'mp4',
-               '22': 'mp4',
-               '37': 'mp4',
-+              '43': 'webm',
-+              '45': 'webm'
-       }
-       @staticmethod