]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
debian/rules: Leave it as vanilla as possible.
[youtubedl] / debian / rules
index 90317821b4125c2a77751a6dbe32b3537494aa58..328323eaabe5d6847fc5fb55402ef4cc70265144 100755 (executable)
@@ -1,33 +1,5 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build:
-
-clean:
-       dh_testdir
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
-
-binary-indep: build install
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman $(CURDIR)/debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: