#!/usr/bin/make -f
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
-build:
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ mv Makefile Makefile.inactive
+ rm youtube-dl
-clean:
- dh_testdir
- dh_clean
+override_dh_install:
+ mv debian/youtube-dl/usr/etc debian/youtube-dl/
+# # For the future (similarly for fish):
+# # dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
+# # etc.
+#
+# mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
+# debian/usr/share/bash-completion/completions/youtube-dl
+ dh_install
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
+override_dh_installdocs:
dh_installdocs
- dh_installman $(CURDIR)/debian/youtube-dl.1
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+ mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+ rmdir debian/youtube-dl/usr/share/doc/youtube_dl
+
+override_dh_clean:
+ -mv Makefile.inactive Makefile
+ -make clean
+ dh_clean
+ rm -rf youtube_dl.egg-info
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: