]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Merge tag 'upstream/2012.02.27+gita171dbf'
[youtubedl] / debian / rules
index 90317821b4125c2a77751a6dbe32b3537494aa58..a1929472ca0f6c28bc061eba168b86f2c9fa322d 100755 (executable)
@@ -1,33 +1,13 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build:
+override_dh_installman:
+       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
+       dh_installman
 
-clean:
-       dh_testdir
-       dh_clean 
+override_dh_auto_build:
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
+override_dh_python2:
 
-       install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
-
-binary-indep: build install
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman $(CURDIR)/debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_pysupport: