]> Raphaël G. Git Repositories - youtubedl/blobdiff - debian/patches/.highlight.css
d/p/remove-autoupdate-mechanism.patch: Update metadata and rename disable-autoupdate...
[youtubedl] / debian / patches / .highlight.css
diff --git a/debian/patches/remove-autoupdate-mechanism.patch b/debian/patches/remove-autoupdate-mechanism.patch
deleted file mode 100644 (file)
index fbff432..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-Subject: Remove autoupdate mechanism
-Bug: 890119
-Forwarded: no
-From: Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
-Reviewed-by: Rogério Theodoro de Brito <rbrito@ime.usp.br>
-Last-Update: 2018-03-16
-Applied-Upstream: no
-
----
- youtube_dl/__init__.py |   8 ++-
- youtube_dl/options.py  |   2 +-
- youtube_dl/update.py   | 187 -------------------------------------------------
- 3 files changed, 6 insertions(+), 191 deletions(-)
- delete mode 100644 youtube_dl/update.py
-
---- a/youtube_dl/__init__.py
-+++ b/youtube_dl/__init__.py
-@@ -438,7 +437,10 @@
-     with YoutubeDL(ydl_opts) as ydl:
-         # Update version
-         if opts.update_self:
--            update_self(ydl.to_screen, opts.verbose, ydl._opener)
-+            parser.error(
-+                "youtube-dl's self-update mechanism is disabled on Debian.\n"
-+                "Please update youtube-dl using apt(8)."
-+            )
-         # Remove cache dir
-         if opts.rm_cachedir:
---- a/youtube_dl/options.py
-+++ b/youtube_dl/options.py
-@@ -140,7 +140,7 @@
-     general.add_option(
-         '-U', '--update',
-         action='store_true', dest='update_self',
--        help='Update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
-+        help=optparse.SUPPRESS_HELP)
-     general.add_option(
-         '-i', '--ignore-errors',
-         action='store_true', dest='ignoreerrors', default=False,