]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/patches/skip_support_file_installation.patch
Update upstream source from tag 'upstream/2020.06.16'
[youtubedl] / debian / patches / skip_support_file_installation.patch
1 From: Carlos Maddela <e7appew@gmail.com>
2 Date: Tue, 1 Mar 2016 02:31:47 +1100
3 Subject: Don't install support files via setup.py
4
5 Description: Don't install support files via setup.py
6 for better control over where they should be installed.
7 Author: Carlos Maddela <e7appew@gmail.com>
8 Origin: vendor
9 Forwarded: not-needed
10 Last-Update: 2016-06-27
11 ---
12 setup.py | 7 +------
13 1 file changed, 1 insertion(+), 6 deletions(-)
14
15 --- a/setup.py
16 +++ b/setup.py
17 @@ -58,12 +58,7 @@
18 if len(sys.argv) >= 2 and sys.argv[1] == 'py2exe':
19 params = py2exe_params
20 else:
21 - files_spec = [
22 - ('etc/bash_completion.d', ['youtube-dl.bash-completion']),
23 - ('etc/fish/completions', ['youtube-dl.fish']),
24 - ('share/doc/youtube_dl', ['README.txt']),
25 - ('share/man/man1', ['youtube-dl.1'])
26 - ]
27 + files_spec = []
28 root = os.path.dirname(os.path.abspath(__file__))
29 data_files = []
30 for dirname, files in files_spec: