]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/rules
d/rules: Run offline tests.
[youtubedl] / debian / rules
1 #!/usr/bin/make -f
2
3 #export DH_VERBOSE = 1
4 export PYBUILD_NAME = youtube_dl
5 export PATH := $(CURDIR)/debian/utils:$(PATH)
6
7 %:
8 dh $@ --with python3 --buildsystem=pybuild --with bash-completion
9
10 override_dh_auto_configure:
11 PREFIX=/usr SYSCONFDIR=/etc make
12 rm youtube-dl
13
14 override_dh_clean:
15 make clean
16 dh_clean
17
18 override_dh_auto_test:
19 ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
20 make offlinetest PYTHON=python3
21 endif