]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/rules
debian/rules: Add commented snippet for conffile removal.
[youtubedl] / debian / rules
1 #!/usr/bin/make -f
2 %:
3 dh $@ --with python2 --buildsystem=python_distutils
4
5 override_dh_auto_configure:
6 PREFIX=/usr SYSCONFDIR=/etc make
7 mv Makefile Makefile.inactive
8 rm youtube-dl
9
10 override_dh_install:
11 mv debian/youtube-dl/usr/etc debian/youtube-dl/
12 # # For the future (similarly for fish):
13 # # dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
14 # # etc.
15 #
16 # mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
17 # debian/usr/share/bash-completion/completions/youtube-dl
18 dh_install
19
20 override_dh_installdocs:
21 dh_installdocs
22 mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
23 rmdir debian/youtube-dl/usr/share/doc/youtube_dl
24
25 override_dh_clean:
26 -mv Makefile.inactive Makefile
27 -make clean
28 dh_clean
29 rm -rf youtube_dl.egg-info