]> Raphaël G. Git Repositories - youtubedl/blob - debian/patches/support-1080p-files.patch
Imported Debian patch 2009.09.13-2
[youtubedl] / debian / patches / support-1080p-files.patch
1 Description: Add support for 1080p videos.
2 Author: Rogério Brito <rbrito@ime.usp.br>
3 --- a/youtube-dl
4 +++ b/youtube-dl
5 @@ -530,12 +530,13 @@
6 _LOGIN_URL = 'http://www.youtube.com/signup?next=/&gl=US&hl=en'
7 _AGE_URL = 'http://www.youtube.com/verify_age?next_url=/&gl=US&hl=en'
8 _NETRC_MACHINE = 'youtube'
9 - _available_formats = ['22', '35', '18', '5', '17', '13', None] # listed in order of priority for -b flag
10 + _available_formats = ['37', '22', '35', '18', '5', '17', '13', None] # listed in order of priority for -b flag
11 _video_extensions = {
12 '13': '3gp',
13 '17': 'mp4',
14 '18': 'mp4',
15 '22': 'mp4',
16 + '37': 'mp4',
17 }
18
19 @staticmethod
20 @@ -1127,7 +1128,7 @@
21 video_format.add_option('-m', '--mobile-version',
22 action='store_const', dest='format', help='alias for -f 17', const='17')
23 video_format.add_option('-d', '--high-def',
24 - action='store_const', dest='format', help='alias for -f 22', const='22')
25 + action='store_const', dest='format', help='alias for -f 37', const='37')
26 parser.add_option_group(video_format)
27
28 verbosity = optparse.OptionGroup(parser, 'Verbosity / Simulation Options')