]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/rules
Imported Debian patch 2009.09.13-2
[youtubedl] / debian / rules
1 #!/usr/bin/make -f
2
3 build: build-stamp
4
5 build-stamp:
6 pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
7 touch $@
8
9 clean:
10 dh_testdir
11 dh_clean build-stamp debian/youtube-dl.1
12
13 install: build
14 dh_testdir
15 dh_testroot
16 dh_clean -k
17 dh_install
18
19 binary-arch:
20 binary-indep: build install
21 dh_testdir
22 dh_testroot
23 dh_installchangelogs
24 dh_installdocs
25 dh_installman debian/youtube-dl.1
26 dh_compress
27 dh_fixperms
28 dh_installdeb
29 dh_gencontrol
30 dh_md5sums
31 dh_builddeb
32
33 binary: binary-indep binary-arch
34 .PHONY: build clean binary-indep binary-arch binary install