1 From: Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
2 Date: Fri, 16 Mar 2018 14:17:40 -0300
3 Subject: Disable upstream's autoupdate mechanism
6 Description: Remove autoupdate mechanism
9 Author: Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
10 Reviewed-by: Rogério Theodoro de Brito <rbrito@ime.usp.br>
11 Last-Update: 2018-03-16
14 youtube_dl/__init__.py | 7 ++++++-
15 youtube_dl/options.py | 2 +-
16 2 files changed, 7 insertions(+), 2 deletions(-)
22 -h, --help Print this help text and exit
23 --version Print program version and exit
24 - -U, --update Update this program to latest version. Make
25 - sure that you have sufficient permissions
26 - (run with sudo if needed)
27 -i, --ignore-errors Continue on download errors, for example to
28 skip unavailable videos in a playlist
29 --abort-on-error Abort downloading of further videos (in the
30 --- a/youtube_dl/__init__.py
31 +++ b/youtube_dl/__init__.py
36 -from .update import update_self
37 from .downloader import (
41 with YoutubeDL(ydl_opts) as ydl:
44 - update_self(ydl.to_screen, opts.verbose, ydl._opener)
46 + "youtube-dl's self-update mechanism is disabled on Debian.\n"
47 + "Please update youtube-dl using apt(8).\n"
48 + "See https://packages.debian.org/sid/youtube-dl for the "
49 + "latest packaged version.\n"
54 --- a/youtube_dl/options.py
55 +++ b/youtube_dl/options.py
59 action='store_true', dest='update_self',
60 - help='Update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
61 + help=optparse.SUPPRESS_HELP)
63 '-i', '--ignore-errors',
64 action='store_true', dest='ignoreerrors', default=False,