]> Raphaël G. Git Repositories - youtubedl/blob - debian/patches/skip-style-checks-for-flake8.patch
d/p/skip-style-checks-for-flake8: Add metadata to please lintian.
[youtubedl] / debian / patches / skip-style-checks-for-flake8.patch
1 Subject: Skip directories and style checks for flake8
2 From: Rogério Theodoro de Brito <rbrito@ime.usp.br>
3 Forwarded: no
4 Last-Update: 2020-04-10
5
6 diff --git a/Makefile b/Makefile
7 index 3e17365..aacc281 100644
8 --- a/Makefile
9 +++ b/Makefile
10 @@ -30,7 +30,10 @@ install: youtube-dl youtube-dl.1 youtube-dl.bash-completion youtube-dl.zsh youtu
11 install -m 644 youtube-dl.fish $(DESTDIR)$(SYSCONFDIR)/fish/completions/youtube-dl.fish
12
13 codetest:
14 - flake8 .
15 + flake8 \
16 + --exclude=.svn,CVS,.bzr,.hg,.git,__pycache__,.tox,.eggs,*.egg,.pc,.pybuild \
17 + --ignore=E121,E123,E126,E226,E24,E704,E402,E501,E731,E741,W503,W504,N802,N803,N806,N816,F401,F821,E302,E305,N801,N815,E265,N813,F403,F405 \
18 + .
19
20 test:
21 #nosetests --with-coverage --cover-package=youtube_dl --cover-html --verbose --processes 4 test