]> Raphaël G. Git Repositories - youtubedl/blob - debian/patches/01-add-support-to-webm.patch
Imported Debian patch 2010.04.04-3
[youtubedl] / debian / patches / 01-add-support-to-webm.patch
1 Description: Add support for webm (VP8 video + Vorbis audio)
2 Author: Rogério Brito <rbrito@ime.usp.br>
3 Forwarded: no
4 Last-Update: 2010-05-29
5
6 --- a/youtube-dl
7 +++ b/youtube-dl
8 @@ -649,13 +649,15 @@
9 _LOGIN_URL = 'http://www.youtube.com/signup?next=/&gl=US&hl=en'
10 _AGE_URL = 'http://www.youtube.com/verify_age?next_url=/&gl=US&hl=en'
11 _NETRC_MACHINE = 'youtube'
12 - _available_formats = ['37', '22', '35', '18', '34', '5', '17', '13', None] # listed in order of priority for -b flag
13 + _available_formats = ['45', '43', '37', '22', '35', '18', '34', '5', '17', '13', None] # listed in order of priority for -b flag
14 _video_extensions = {
15 '13': '3gp',
16 '17': 'mp4',
17 '18': 'mp4',
18 '22': 'mp4',
19 '37': 'mp4',
20 + '43': 'webm',
21 + '45': 'webm'
22 }
23
24 @staticmethod