]> Raphaël G. Git Repositories - youtubedl/blob - debian/patches/disable-autoupdate-mechanism.patch
debian/patches: Refresh patches to apply cleanly.
[youtubedl] / debian / patches / disable-autoupdate-mechanism.patch
1 From: Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
2 Date: Fri, 16 Mar 2018 14:17:40 -0300
3 Subject: Disable upstream's autoupdate mechanism
4
5
6 Description: Remove autoupdate mechanism
7 Bug-Debian: 890119
8 Forwarded: not-needed
9 Author: Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
10 Reviewed-by: Rogério Theodoro de Brito <rbrito@ime.usp.br>
11 Last-Update: 2018-03-16
12
13 ---
14 youtube_dl/__init__.py | 7 ++++++-
15 youtube_dl/options.py | 2 +-
16 2 files changed, 7 insertions(+), 2 deletions(-)
17
18 --- a/youtube_dl/__init__.py
19 +++ b/youtube_dl/__init__.py
20 @@ -441,7 +441,12 @@
21 with YoutubeDL(ydl_opts) as ydl:
22 # Update version
23 if opts.update_self:
24 - update_self(ydl.to_screen, opts.verbose, ydl._opener)
25 + parser.error(
26 + "youtube-dl's self-update mechanism is disabled on Debian.\n"
27 + "Please update youtube-dl using apt(8).\n"
28 + "See https://packages.debian.org/sid/youtube-dl for the "
29 + "latest packaged version.\n"
30 + )
31
32 # Remove cache dir
33 if opts.rm_cachedir:
34 --- a/youtube_dl/options.py
35 +++ b/youtube_dl/options.py
36 @@ -140,7 +140,7 @@
37 general.add_option(
38 '-U', '--update',
39 action='store_true', dest='update_self',
40 - help='Update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
41 + help=optparse.SUPPRESS_HELP)
42 general.add_option(
43 '-i', '--ignore-errors',
44 action='store_true', dest='ignoreerrors', default=False,