]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/patches/0001-Fix-downloading-of-videos-from-facebook.patch
debian/control: Add python to B-D-Indep. Closes: #647407.
[youtubedl] / debian / patches / 0001-Fix-downloading-of-videos-from-facebook.patch
1 From 4b71bc3cfef0672726beaaa26e1c57c7eca33790 Mon Sep 17 00:00:00 2001
2 From: =?UTF-8?q?Rog=C3=A9rio=20Brito?= <rbrito@ime.usp.br>
3 Date: Sat, 22 Oct 2011 01:12:46 -0200
4 Subject: [PATCH] Fix downloading of videos from facebook.
5
6 ---
7 youtube-dl | 6 +++---
8 1 files changed, 3 insertions(+), 3 deletions(-)
9
10 --- a/youtube-dl
11 +++ b/youtube-dl
12 @@ -2712,8 +2712,9 @@
13 _VALID_URL = r'^(?:https?://)?(?:\w+\.)?facebook\.com/video/video\.php\?(?:.*?)v=(?P<ID>\d+)(?:.*)'
14 _LOGIN_URL = 'https://login.facebook.com/login.php?m&next=http%3A%2F%2Fm.facebook.com%2Fhome.php&'
15 _NETRC_MACHINE = 'facebook'
16 - _available_formats = ['highqual', 'lowqual']
17 + _available_formats = ['video', 'highqual', 'lowqual']
18 _video_extensions = {
19 + 'video': 'mp4',
20 'highqual': 'mp4',
21 'lowqual': 'mp4',
22 }
23 @@ -2741,10 +2742,9 @@
24 def _parse_page(self, video_webpage):
25 """Extract video information from page"""
26 # General data
27 - data = {'title': r'class="video_title datawrap">(.*?)</',
28 + data = {'title': r'\("video_title", "(.*?)"\)',
29 'description': r'<div class="datawrap">(.*?)</div>',
30 'owner': r'\("video_owner_name", "(.*?)"\)',
31 - 'upload_date': r'data-date="(.*?)"',
32 'thumbnail': r'\("thumb_url", "(?P<THUMB>.*?)"\)',
33 }
34 video_info = {}