]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/patches/fix-809454.patch
Imported Debian patch 2015.11.27.1-1.1
[youtubedl] / debian / patches / fix-809454.patch
1 Description: Apply youtube fix from upstream issue 7900
2 * Fix for youtube failure #809454
3 Author: Wookey <wookey@debian.org>
4
5 Origin: upstream, https://github.com/rg3/youtube-dl/commit/b95779be21929c1aed1c0edbc3f9a5d11826973f
6 Bug: https://github.com/rg3/youtube-dl/issues/7900
7 Bug-Debian: https://bugs.debian.org/809454
8 Forwarded: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809454#3
9 Last-Update: 2016-01-07
10
11 --- youtube-dl-2015.11.27.1.orig/youtube_dl/jsinterp.py
12 +++ youtube-dl-2015.11.27.1/youtube_dl/jsinterp.py
13 @@ -232,7 +232,7 @@ class JSInterpreter(object):
14 def extract_function(self, funcname):
15 func_m = re.search(
16 r'''(?x)
17 - (?:function\s+%s|[{;]%s\s*=\s*function|var\s+%s\s*=\s*function)\s*
18 + (?:function\s+%s|[{;,]%s\s*=\s*function|var\s+%s\s*=\s*function)\s*
19 \((?P<args>[^)]*)\)\s*
20 \{(?P<code>[^}]+)\}''' % (
21 re.escape(funcname), re.escape(funcname), re.escape(funcname)),