]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Install support files via debhelper instead of setup.py.
[youtubedl] / debian / rules
index 3ee2eb64cfc2da0fd5a5e7e95bc018ffa22f7c8c..9c645f1c863c90c91a71d29ad84cb96a3d6d86dd 100755 (executable)
@@ -1,7 +1,17 @@
 #!/usr/bin/make -f
 %:
-       dh $@ --buildsystem=python_distutils
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
-override_dh_install:
-       mv debian/youtube-dl/usr/etc debian/youtube-dl/
-       dh_install
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: