]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Install support files via debhelper instead of setup.py.
[youtubedl] / debian / rules
index 1e2fae8bf36942b6bb07c3b78f7ab3158cb87754..9c645f1c863c90c91a71d29ad84cb96a3d6d86dd 100755 (executable)
@@ -1,7 +1,17 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
-override_dh_installman:
-       pod2man debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: