]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Install support files via debhelper instead of setup.py.
[youtubedl] / debian / rules
index 90317821b4125c2a77751a6dbe32b3537494aa58..9c645f1c863c90c91a71d29ad84cb96a3d6d86dd 100755 (executable)
@@ -1,33 +1,17 @@
 #!/usr/bin/make -f
 #!/usr/bin/make -f
+%:
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
 
-build:
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
 
 
-clean:
-       dh_testdir
-       dh_clean 
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
 
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
-
-binary-indep: build install
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman $(CURDIR)/debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: