]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Install support files via debhelper instead of setup.py.
[youtubedl] / debian / rules
index d596fb2ee748f685d5312a109f7f3651fe52a4d5..9c645f1c863c90c91a71d29ad84cb96a3d6d86dd 100755 (executable)
@@ -1,8 +1,17 @@
 #!/usr/bin/make -f
 %:
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
 
-override_dh_auto_install:
-       dh_install
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
 
 override_dh_auto_test:
 
 override_dh_auto_test: