]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Install support files via debhelper instead of setup.py.
[youtubedl] / debian / rules
index 328323eaabe5d6847fc5fb55402ef4cc70265144..9c645f1c863c90c91a71d29ad84cb96a3d6d86dd 100755 (executable)
@@ -1,5 +1,17 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
 
 override_dh_auto_test: