Make it buildable with gcc 5.5.0
authorRaphaël Gertz <git@rapsys.eu>
Tue, 1 May 2018 22:20:02 +0000 (00:20 +0200)
committerRaphaël Gertz <git@rapsys.eu>
Tue, 1 May 2018 22:20:02 +0000 (00:20 +0200)
cmake/compiler/gcc/settings.cmake

index 9139a028f18aeaf72d4a8d340949dbdec42b43f7..8d8e601c8d342d1ef62d23b05e6b7d3528c42b34 100644 (file)
@@ -3,7 +3,7 @@ target_compile_definitions(trinity-compile-option-interface
   INTERFACE
     -D_BUILD_DIRECTIVE="${CMAKE_BUILD_TYPE}")
 
-set(GCC_EXPECTED_VERSION 6.3.0)
+set(GCC_EXPECTED_VERSION 5.5.0)
 
 if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS GCC_EXPECTED_VERSION)
   message(FATAL_ERROR "GCC: TrinityCore requires version ${GCC_EXPECTED_VERSION} to build but found ${CMAKE_CXX_COMPILER_VERSION}")